1. 首页>
  2. 资讯中心

【安全通告】Apache HTTP Server路径穿越及远程代码执行漏洞风险通告(CVE-2021-41773、CVE-2021-42013)

腾讯云 2021年10月22日 浏览958

    新闻 资讯 腾讯云代理 腾讯云直播申请 游戏上云

摘要:

尊敬的腾讯云用户,您好!

 

腾讯云安全运营中心监测到,Apache官方发布安全通告,披露了Apache HTTP Server存在路径穿越漏洞及远程代码执行漏洞,漏洞编号CVE-2021-41773。由于修复不完善,导致新版本2.4.50依旧存在漏洞,新漏洞编号CVE-2021-42013。

 

为避免您的业务受影响,腾讯云安全建议您及时开展安全自查,如在受影响范围,请您及时进行更新修复,避免被外部攻击者入侵。

 

漏洞详情

Apache HTTP Server(HTTPd)是Apache软件基金会的一个开放源代码的网页服务器。
 

Apache HTTP Server 2.4.49版本对路径规范化所做的更改中存在一个路径穿越漏洞,攻击者可利用该漏洞读取到Web目录外的其他文件,如系统配置文件、网站源码等,甚至在特定情况下,攻击者可构造恶意请求执行命令,控制服务器。

 

由于修复不完善Apache HTTP Server 2.4.50版本依旧存在该漏洞。


且目前已存在在野利用。

 

风险等级

 

漏洞风险

攻击者可利用该漏洞获得敏感信息甚至远程执行代码

 

影响版本

Apache HTTP Server 2.4.49及2.4.50版本

 

安全版本

Apache HTTP Server >= 2.4.51

Apache HTTP Server 非 2.4.49、2.4.50版

 

修复建议

升级到Apache HTTP Server最新安全版本,或使用Apache HTTP Server 非 2.4.49、2.4.50版可无需升级

 

【备注】:建议您在升级前做好数据备份工作,避免出现意外

 

漏洞参考

https://httpd.apache.org/security/vulnerabilities_24.html

相关文章

腾讯云服务器

为企业提供:云服务器/视频/游戏/微信开发/软件/网站/APP…云解决方案

  • QQ群咨询:377986805 咨询电话:15818558013
  • 技术支持:0755-33940501-808 17603077568
  • 产品咨询:0755-33940501-803 15818558013