1. 首页>
  2. 资讯中心

【安全通告】Apache Airflow远程代码执行漏洞风险通告(CVE-2021-38540)

腾讯云 2021年10月22日 浏览39

    新闻 资讯 腾讯云代理 腾讯云直播申请 游戏上云

摘要:

尊敬的腾讯云用户,您好!

 

腾讯云安全运营中心监测到,Apache官方发布安全通告,披露了Apache Airflow远程代码执行漏洞,漏洞编号CVE-2021-38540。

 

为避免您的业务受影响,腾讯云安全建议您及时开展安全自查,如在受影响范围,请您及时进行更新修复,避免被外部攻击者入侵。

 

漏洞详情

Apache Airflow是美国阿帕奇(Apache)基金会的一套用于创建、管理和监控工作流程的开源平台。

 

据官方描述,由于Variable Import endpoint的身份验证不正确,Apache Airflow 可能允许远程攻击者在系统上执行任意代码。攻击者可以通过发送特制的请求来添加或修改 DAG 中使用的 Airflow 变量,从而利用该漏洞执行任意代码、获取敏感信息或造成拒绝服务。

 

风险等级

 

漏洞风险

攻击者可利用该漏洞

 

影响版本

Apache Airflow >=2.0.0, <2.1.3

 

安全版本

Apache Airflow >= 2.1.3

 

修复建议

升级到Apache Airflow最新安全版本

 

官方链接:

https://github.com/apache/airflow

 

【备注】:建议您在升级前做好数据备份工作,避免出现意外

 

漏洞参考

https://nvd.nist.gov/vuln/detail/CVE-2021-38540

相关文章

腾讯云服务器

为企业提供:云服务器/视频/游戏/微信开发/软件/网站/APP…云解决方案

  • QQ群咨询:377986805 咨询电话:15818558013
  • 技术支持:0755-33940501-808 17603077568
  • 产品咨询:0755-33940501-803 15818558013